php升级自带的json版本

  因为我们要用到elasticsearch这个搜索引擎,php默认自带的json扩展是1.2.1版本的。es需要1.3.7以上的json版本。如何升级json扩展这个问题上面纠结了两个小时。最终还是被我解决了

## 说一下解决的思路:

重新编译php,使用--disable-json禁用自带的json。因为如果你要启用新的json,就会和老的json冲突。

### 安装步骤

tar -xf jsonc-1.3.7.tgz && cd  jsonc-1.3.7
./configure --with-php-config=/usr/local/data/php/bin/php-config
make && make install

### 给php增加扩展

[root@pngtree_web ~]# cat /usr/local/data/php/etc/php.ini  | grep json
[json]
extension = json.so

### 重启php

service php-fpm reload

wKiom1h2HAbze6koAAANQbA8dcI252.png

本文出自 “不抛弃!不放弃” 博客,请务必保留此出处http://thedream.blog.51cto.com/6427769/1891172

赞 (0) 评论 分享 ()